July 2022 Archives by thread
Starting: Fri Jul 1 04:08:18 GMT 2022
Ending: Sun Jul 31 23:59:14 GMT 2022
Messages: 541
- 2.39 Release Schedule
Matthias Klose
- [PATCH 1/7] x86: don't leak sub-architecture accumulated strings
Jan Beulich
- PING: [PATCH] aarch64: Disallow copy relocations on protected data
Matthias Klose
- [PATCH] Fix range lists issues (dwarf-5)
Nick Clifton
- New port for Kalray processors
Nick Clifton
- [PATCH] Modified changes for split-dwarf and dwarf-5
Kumar N, Bhuvanendra
- [RESEND PATCH 0/1] RISC-V: Update 'Zihintpause' extension version
Tsukasa OI
- binutils builder.sourceware.org status
Mark Wielaard
- ☺ Buildbot (GNU Toolchain): binutils-gdb - build successful (master)
builder@sourceware.org
- ☠ Buildbot (GNU Toolchain): binutils-gdb - failed test (failure) (master)
builder@sourceware.org
- buildbot users try branch builders
Jan Beulich
- [PATCH 2/2] libopcodes/aarch64: add support for disassembler styling
Nick Clifton
- ☠ Buildbot (GNU Toolchain): binutils-gdb - failed update (failure) (master)
builder@sourceware.org
- Commit: Update libiberty's rust demangler
Nick Clifton
- objcopy: bfd_alloc orelocation
Alan Modra
- alloc gas seginfo on notes obstack
Alan Modra
- [PATCH] Support for location and range lists for split-dwarf and dwarf-5
Kumar N, Bhuvanendra
- [PATCH] bfd: Fix issues with files in debug_line table with dwarf5.
Potharla, Rupesh
- [PATCH v2 0/4] gas/x86: .arch / -march= enhancements
Jan Beulich
- [PATCH 0/3] gas/x86: operand handling (mainly when swapping)
Jan Beulich
- [PATCHv2 0/2] AArch64 libopcodes styling
Andrew Burgess
- [PATCH v2 3/8] RISC-V: Add Zfhmin/Zhinxmin (with refactoring)
Kito Cheng
- [PATCH] Descriptive DWARF operations dump support for DW_AT_rank
Kumar N, Bhuvanendra
- [PATCH] elf: Copy p_align of PT_GNU_STACK for stack alignment
H.J. Lu
- Deliberate deduplication of -rpath arguments in ld.bfd and ld.gold?
Stephan Bergmann
- [PATCH] x86: re-order insn template fields
Jan Beulich
- [PATCH] gprofng: adjust GPROFNG_VARIANT
vladimir.mezentsev@oracle.com
- [PATCH v2 4/8] RISC-V: Fix disassembling Zfinx with -M numeric
Kito Cheng
- [PATCH v3 1/2] RISC-V: Fix requirement handling on Zhinx+{D,Q}
Kito Cheng
- [PATCH] libopcodes/s390: add support for disassembler styling
Andrew Burgess
- [PATCH] gprofng: fix regression in testing for not yet installed version
vladimir.mezentsev@oracle.com
- ☠ Buildbot (GNU Toolchain): binutils-gdb - failed compile (failure) (master)
builder@sourceware.org
- 2.39 branch is now open for commits
Nick Clifton
- [PATCH] ld: aarch64: Update test linker scripts relocs.ld and relocs-ilp32.ld
Matthew Malcomson
- [PATCH] ld: aarch64: Improve TLS relaxation condition
Matthew Malcomson
- New template for 'binutils' made available
Translation Project Robot
- New template for 'bfd' made available
Translation Project Robot
- New template for 'gas' made available
Translation Project Robot
- New template for 'gold' made available
Translation Project Robot
- New template for 'ld' made available
Translation Project Robot
- New template for 'opcodes' made available
Translation Project Robot
- New Ukrainian PO file for 'gold' (version 2.38.90)
Translation Project Robot
- New Ukrainian PO file for 'ld' (version 2.38.90)
Translation Project Robot
- New Ukrainian PO file for 'gas' (version 2.38.90)
Translation Project Robot
- New Ukrainian PO file for 'bfd' (version 2.38.90)
Translation Project Robot
- New Ukrainian PO file for 'binutils' (version 2.38.90)
Translation Project Robot
- [PATCH 0/1] RISC-V: Use faster hash table on disassembling
Tsukasa OI
- [PATCH 0/2] RISC-V: Make some instruction non-aliases to fix a disassembler issue
Tsukasa OI
- [PATCH 0/2] RISC-V: Improve "bits undefined" diagnostics
Tsukasa OI
- [PATCH 0/1] RISC-V: Add `OP_V' to .insn named opcodes
Tsukasa OI
- [REVIEW ONLY 0/2] RISC-V (unratified): Add 'Zihintntl' extension
Tsukasa OI
- [PATCH 0/3] RISC-V: Add 'Zmmul' extension
Tsukasa OI
- [REVIEW ONLY 0/1] RISC-V (unratified): Add 'Smrnmi' extension
Tsukasa OI
- [PATCH 0/5] RISC-V: Opcode tidying (batch 1)
Tsukasa OI
- Regenerate with automake-1.15.1
Alan Modra
- gas: arm -mwarn-syms duplicates
Alan Modra
- gas: utility notes memory alloc functions
Alan Modra
- gas: output_file_close
Alan Modra
- free read_symbol_name string
Alan Modra
- read.c: use string hash from hash.h for po_hash
Alan Modra
- macro.c: use string hash from hash.h for macro_hash
Alan Modra
- read.c s_include: use notes obstack for path
Alan Modra
- read.c assign_symbol: use notes obstack for dummy listing frag
Alan Modra
- expr.c make_expr_symbol: use notes obstack
Alan Modra
- dw2gencfi.c: use notes obstack
Alan Modra
- gas: free sy_hash, macro_hash and po_hash
Alan Modra
- gas: itbl_files
Alan Modra
- gas: set up notes obstack earlier
Alan Modra
- gas: rename md_end to md_finish
Alan Modra
- gas hash.h tidy
Alan Modra
- ppc gas: don't leak ppc_hash memory
Alan Modra
- i386 gas: don't leak op_hash or reg_hash memory
Alan Modra
- arc gas: don't leak arc_opcode_hash memory
Alan Modra
- gas: target string hash tables
Alan Modra
- gas: use notes_calloc in string hash
Alan Modra
- gas: tc-tic54x.c hash tables
Alan Modra
- Teaching expression() to treat some operations specially
Dmitry Selyutin
- [PATCH v3 0/4] RISC-V: Combined floating point enhancements
Tsukasa OI
- [PATCH] RISC-V: Support Zmmul extension
shihua@iscas.ac.cn
- New Swedish PO file for 'binutils' (version 2.38.90)
Translation Project Robot
- Arm binutils buildbot workers
Christophe Lyon
- glibc 2.36 - Slushy freeze (3 weeks to release)
Xi Ruoyao
- New French PO file for 'binutils' (version 2.38.90)
Translation Project Robot
- PR29355, ld segfaults with -r/-q and custom-named section .rela*
Alan Modra
- PowerPC md_end: Don't htab_delete(NULL)
Alan Modra
- [PATCH] toplevel: Makefile.def: Make configure-sim depend on all-readline
Luis Machado
- [PATCH] LTO plugin: sync header file with GCC
Martin Liška
- [PATCH] libopcodes/ppc: add support for disassembler styling
Andrew Burgess
- [PATCH 0/1] ppc: support register names in macros
Dmitry Selyutin
- [PATCH 0/2] gas: Minor strings fix on June 2022 (Mach-O and RISC-V)
Tsukasa OI
- [PATCH] RISC-V: Use `xlen' on ADDIW address sequence
Tsukasa OI
- [RFC] gas: RISC-V: Add support for RV64E/lp64e
Palmer Dabbelt
- [PATCH] RISC-V: Add --[no-]relax-gp to ld
Fangrui Song
- [RISCV] RISC-V GNU Toolchain Biweekly Sync-up call (July 14, 2022)
jiawei@iscas.ac.cn
- [PATCH] RISC-V: fix printf types on riscv-dis.c
Tsukasa OI
- LTO seems to change the outcome of the division by zero raises SIGFPE test.
Kao Dome
- About 329338 - Declaration conflict for basename
Vladimir Mezentsev
- [PATCH] sim/testsuite: Trim extra path from arch
Tsukasa OI
- Personal AD offer
Max
- RISC-V: Public review for Non-ISA Specification: psABI
Kito Cheng
- [PATCH] gprofng: fix regression in build and a rice condition in autoreconf
vladimir.mezentsev@oracle.com
- New French PO file for 'gas' (version 2.38.90)
Translation Project Robot
- [PATCH] gas/symbols: do not panic upon resolving O_md
Dmitry Selyutin
- [PATCH] x86: correct VMOVSH attributes
Jan Beulich
- [PATCH v2] x86: re-order insn template fields
Jan Beulich
- [PATCH 2/2] gprofng: link libgprofng.so against -lpthread
vladimir.mezentsev@oracle.com
- New French PO file for 'bfd' (version 2.38.90)
Translation Project Robot
- [PATCH,V5 00/10] Definition and Implementation of CTF Frame format
Indu Bhagat
- [PATCH,V5 01/10] ctf-frame.h: Add CTF Frame format definition
Indu Bhagat
- [PATCH,V5 02/10] gas: add new command line option --gctf-frame
Indu Bhagat
- [PATCH 1/5 v1] LoongArch: bfd: Add new reloc types.
liuzhensong
- [committed 1/2] arc: Update missing cipher.
Claudiu Zissulescu
- [PATCH][Binutils][GAS] arm: Add cfi expression support for ra_auth_code
Victor Do Nascimento
- [PATCH] x86: Properly check invalid relocation against protected symbol
H.J. Lu
- [PATCH] x86: Make protected symbols local for -shared
H.J. Lu
- [PATCH 1/2] opcodes/loongarch: Remove unused code
WANG Xuerui
- [PATCH 2/2] opcodes/loongarch: Implement style support in the disassembler
WANG Xuerui
- [PATCH] binutils-gdb/git: highlight whitespace errors in source files
Andrew Burgess
- [PATCH] [AArch64] Support AArch64 MTE memory tag dumps in core files
Luis Machado
- [PATCH] ld: Add support for a new option, -exclude-symbols, in COFF object file directives
Martin Storsjo
- New Georgian PO file for 'gprof' (version 2.36.90)
Translation Project Robot
- [PATCH] x86/Intel: correct AVX512F scatter insn element sizes
Jan Beulich
- New Russian PO file for 'gas' (version 2.38.90)
Translation Project Robot
- [PATCH] x86: replace wrong attributes on VCVTDQ2PH{X,Y}
Jan Beulich
- Supporting RISC-V Vendor Extensions in the GNU Toolchain
Palmer Dabbelt
- PowerPC: Create new MMA instruction masks and use them
Peter Bergner
- [PATCH v2 0/6] Add new relocations for LoongArch.
liuzhensong
- [PATCH v2 6/6] LoongArch: Add testcases for new relocate types.
liuzhensong
- PowerPC64: fix build error on 32-bit hosts
Alan Modra
- miscellaneous dwarf.c tidies
Alan Modra
- binutils/dwarf.c: abbrev caching
Alan Modra
- PR29370, infinite loop in display_debug_abbrev
Alan Modra
- PR29337, readelf CU/TU mixup in .gdb_index
Alan Modra
- ☝ Buildbot (GNU Toolchain): binutils-gdb - retry lost connection test (retry) (master)
builder@sourceware.org
- PR29390, DW_CFA_AARCH64_negate_ra_state vs. DW_CFA_GNU_window_save
Alan Modra
- Cross-compilation related bug
Sim Tov
- [PATCH] i386: Don't allow GOTOFF relocation against IFUNC symbol for PIC
H.J. Lu
- PR15951, binutils testsuite builds status wrapper unconditionally
Alan Modra
- PR17122, OSX 10.9 build failure
Alan Modra
- [PATCH][Binutils][GAS] arm: Fix DWARF pseudo-register numbering convention
Victor Do Nascimento
- [PATCH] gprofng: fix bug 29351 - Move dynamic loading of modules to a later stage
ruud.vanderpas@oracle.com
- [PATCH] gprofng: fix bug 29352 - Fix the message Hexadecimal number > 0xffffffff non-portable
ruud.vanderpas@oracle.com
- [PATCH] gprofng: fix bug 29353 - Fix a lay-out issue in the html disassembly files
ruud.vanderpas@oracle.com
- [PATCH] ld: Compile 2 CTF tests with -O2
H.J. Lu
- [PATCH] gprofng: fix bug 29356 - Execution fails if gprofng is not included in PATH
ruud.vanderpas@oracle.com
- [PATCH] gprofng: fix bug 29392 - Unexpected line format in summary file
ruud.vanderpas@oracle.com
- [PATCH v2 1/2] ld: Add support for a new option, -exclude-symbols, in COFF object file directives
Martin Storsjo
- [PATCH v2 2/2] ld: Support the -exclude-symbols option via COFF def files, with the EXCLUDE_SYMBOLS keyword
Martin Storsjo
- PowerPC64 .branch_lt address
Alan Modra
- [PATCH] LoongArch: Set defaults to exec stack 0.
liuzhensong
- buildbot vs --enable-targets=all
Mark Wielaard
- New French PO file for 'gold' (version 2.38.90)
Translation Project Robot
- New French PO file for 'ld' (version 2.38.90)
Translation Project Robot
- [PATCH v6 0/7] ppc/svp64: support SVP64 and its first insns
Dmitry Selyutin
- [PATCH] Add pdb archive target
Mark Harmstone
- [PATCH] gprofng: check for the makeinfo version
vladimir.mezentsev@oracle.com
- Commit: Fix compile time warning in elfnn-loongarch.c
Nick Clifton
- [PATCH] gold: add --package-metadata
luca.boccassi@gmail.com
- [PATCH] LoongArch: Deprecate $v[01] and $fv[01] names per spec
WANG Xuerui
- [PATCH 0/2] opcodes: LoongArch: Cleanups to jumps
WANG Xuerui
- [PATCH 1/2] opcodes: LoongArch: make all non-native jumps desugar to canonical b{lt/ge}[u] forms
WANG Xuerui
- [PATCH 2/2] opcodes: LoongArch: add "ret" instruction to reduce typing
WANG Xuerui
- [RISCV] RISC-V GNU Toolchain Meeting Cancell (July, 28, 2022)
jiawei@iscas.ac.cn
- [PATCH] x86: SKINIT with operand needs IgnoreSize
Jan Beulich
- [PATCH] x86: drop stray NoRex64 from KeyLocker insns
Jan Beulich
- [PATCH] Arm64: re-work PR gas/27217 fix
Jan Beulich
- your change "x86: Also pass -P to $(CPP) when processing i386-opc.tbl"
Jan Beulich
- [PATCH v3 1/2] ld: Add support for a new option, -exclude-symbols, in COFF object file directives
Martin Storsjo
- [PATCH v3 2/2] ld: Support the -exclude-symbols option via COFF def files, with the EXCLUDE_SYMBOLS keyword
Martin Storsjo
- [PATCH] ld: Extend ac_default_ld_warn_rwx_segments to all SPARC targets [PR29411]
Rainer Orth
- Fwd: [PATCH] x86: Also pass -P to $(CPP) when processing i386-opc.tbl
H.J. Lu
- [PATCH v2][Binutils][GAS] arm: Use DWARF numbering convention for pseudo-register representation
Victor Do Nascimento
- [PATCH] RISC-V/t-head: Add CSRs and opcodes of the T-HEAD XUANTIE CPUs
Palmer Dabbelt
- [PATCH v2] x86: SKINIT with operand needs IgnoreSize
Jan Beulich
- [PATCH] Support multiple .eh_frame sections
Jojo R
- PR16005, avr linker crash on a particular instruction sequence with --relax
Alan Modra
- [PATCH 0/3] RISC-V: Fix address printer on the disassembler
Tsukasa OI
- [PATCH v3][Binutils][GAS] arm: Use DWARF numbering convention for pseudo-register representation
Victor Do Nascimento
- [PATCH] gold/aarch64: Fix adrp distance check
Cary Coutant
- [RFC PATCH 0/3] RISC-V: Check shift amount against XLEN (disassembler)
Tsukasa OI
- [PATCH 0/1] RISC-V: Check shift amount against XLEN (disassembler)
Tsukasa OI
- [PATCH 0/3] RISC-V: Implement "generic subsets" for disassembler
Tsukasa OI
- PR29348, BFD_VMA_FMT wrong
Alan Modra
Last message date:
Sun Jul 31 23:59:14 GMT 2022
Archived on: Sun Jul 31 23:59:25 GMT 2022
This archive was generated by
Pipermail 0.09 (Mailman edition).