[PATCH 1/5 v1] LoongArch: bfd: Add new reloc types.

Xi Ruoyao xry111@xry111.site
Wed Jul 20 05:19:01 GMT 2022


On Wed, 2022-07-20 at 12:03 +0800, WANG Xuerui wrote:
> On 2022/7/20 10:07, liuzhensong wrote:
> > 
> > Some relocation name changes make sense. But, how to name a name is a 
> > matter of personal aesthetics, and it is difficult to satisfy 
> > everyone. Does the name of the relocation matter? should we pay more
> > attention to the specific implementation?  Remove useless and add needed?

A bug fix needs immediately attention, but a new feature may need more
discussion to make it easier to be used correctly.  I'm still reluctant
about "adding a whole bunch of new relocation just 3 weeks before
Binutils-2.39 release date".

> 
> Also, if you think the current names are more appropriate, with 
> objective reasons, then *please communicate* your justification and 
> thought behind them. We "outsiders" actually intend to cooperate, and 
> have voiced our thoughts, but we don't know what you and your team 
> think. For now all we have is this "LO12/HI20/LO20/HI12" and outsiders
> can draw no conclusion other than "hmm this is going to cause 
> confusion". We really need to communicate more in the open for pushing
> things forward, constructively.

About "LO12/HI20/LO20/HI12" vs "0/12/32/52", please consider: if someone
has not read LoongArch manual, he'll have no idea about what is "HI20"
and likely [mis]interpret it as "x[63:44]" instead of "x[51:32]".  But
if he has read LoongArch manual, the manual already uses
"LU12I.W/LU32I.D/LU52I.D".  So a different notion for the parts of
immediate seems a completely unnecessary deviation.

-- 
Xi Ruoyao <xry111@xry111.site>
School of Aerospace Science and Technology, Xidian University


More information about the Binutils mailing list