December 2025 Archives by thread
Starting: Mon Dec 1 01:27:44 GMT 2025
Ending: Wed Dec 31 19:12:38 GMT 2025
Messages: 883
- [PATCH] mips: Assert dynamic symbol counts only with dynamic sections
Alan Modra
- [PATCH] RISC-V: Check if the merged ISA string is conflicting
Yu-Cheng Liang
- [PATCH] hppa64: Set has_local_dynsyms when adding __text_seg/__data_seg
H.J. Lu
- [PATCH v2 00/10] mips hi16/lo16 reloc handling
Maciej W. Rozycki
- [PING][PATCH v2 00/10] mips hi16/lo16 reloc handling
Maciej W. Rozycki
- [PATCH 0/4] x86: support APX-NCI-NDD-NF
Jiang, Haochen
- [PATCH 1/4] x86: sub-divide APX_F - NCI
Jiang, Haochen
- bogus FAILs from mmix ld testsuite
Hans-Peter Nilsson
- GNU Tools Weekly News Week 14 (November 30, 2025)
GNU Tools weekly
- [PATCH v2] RISC-V: Fix incorrect DW_AT_high_pc after linker relaxation
Yu-Cheng Liang
- [PATCH] LoongArch: Add support for the ud macro instruction
Lulu Cai
- [PATCH] Fix binutils build on hppa64-hpux with gcc-16
Jan Beulich
- [PATCH v10 06/28] gas: implement parsing of object attributes v2
Jan Beulich
- [PATCH v6] Add AMD znver6 processor support
Kalvakuntla, Umesh
- [PATCH v1] PowerPC: Support for Additional Performance Monitor Counters (RFC02666)
Surya Kumari Jangala
- [PATCH v7] Add AMD znver6 processor support
Umesh Kalvakuntla
- [PATCH] Cleanup bfd target vectors and ld emulations on Solaris
Rainer Orth
- [PATCH v3] PowerPC: Support for eTCE (RFC02662)
Surya Kumari Jangala
- [PATCH v2] PowerPC: Support for Additional Performance Monitor Counters (RFC02666)
Abhay Kandpal
- ☠ Buildbot (Sourceware): binutils-gdb-autoregen - failed update (failure) (master)
builder@sourceware.org
- [PATCH] x86: traverse loc_hash_table only if used
H.J. Lu
- [PATCH v4] PowerPC: Support for eTCE (RFC02662)
Abhay Kandpal
- [PATCH] ld/ELF: leave note sections alone for relocatable linking
Jan Beulich
- [PATCH 00/13] sframe: some refactoring and misc improvements
Indu Bhagat
- https://binutils.sourceware.narkive.com/
Alvina Frendous
- copyrights still referencing the old postal FSF address
Matthias Klose
- your patch "aarch64: Remove teecr32_el1 and teehbr32_el1"
Jan Beulich
- Commit: Binutils: Add support for DW_AT_language_name and DW_AT_language_version
Nick Clifton
- [PATCH v2 00/12] Add support for LoongArch32
mengqinggang
- [PATCH 0/2] aarch64: Add FEAT_MOPS_GO instructions
Yury Khrustalev
- [PATCH v1]RISC-V: Zcmt relaxationi support.
Umesh Kalappa
- [PATCH] binutils-gdb/git: Handle *.ac and *.m4 files in .gitattributes
Tom de Vries
- [PATCH 0/2] sframe: Fix for PR 33401
claudiu.zissulescu-ianculescu@oracle.com
- [PATCH] ld/ELF: correct tidying of sec64k object files
Jan Beulich
- [PATCH] MAINTAINERS: move three people to "Past Maintainers"
Jan Beulich
- gas scrubber (again)
Jan Beulich
- [PING] [PATCH v2 00/15] Integrate MIPS-Specific Support
Jovan Dmitrovic
- [PATCH] Fix binutils build on hppa64-hpux with gcc-16 (v2)
John David Anglin
- [COMMITTED, PATCH] copy_object: Re-indent
H.J. Lu
- [PATCH] elf: Keep section symbols for Solaris symbol sort sections
H.J. Lu
- [PATCH] Add windres to TOOL_PROGS
Peter Damianov
- [PATCH v2] Obsolete support for Solaris < 10
Jan Beulich
- [PATCH] gas/macro: drop ISSEP()
Jan Beulich
- Commit: readelf: warn about local symbols outside of a mergeable section
Nick Clifton
- [PATCH v1 0/3] aarch64: Add support for POE2 extension.
Srinath Parvathaneni
- [PATCH] x86: replace XFAILs in "GOTX default" tests
Jan Beulich
- hppa64 linker crash on ld-elf/pr22269 testcase
Jan Beulich
- [PATCH v3 01/18] PR binutils/33485: LD/testsuite: Also XFAIL `ns32k-*-*' targets
Jan Beulich
- [PATCH v3 03/18] VMS/BFD: Fix a sign extension issue with archive symbol lookup
Jan Beulich
- [PATCH v3 02/18] LD/testsuite: Fix archive verification for Alpha/VMS
Jan Beulich
- [PATCH v3 04/18] LD/testsuite: Expand archive verification to `--whole-archive' feature
Jan Beulich
- [PATCH 0/4] aarch64: Improve sysreg print_operand notes
Alice Carlotti
- [PATCH 1/2] aarch64: Add support for FEAT_LSCP.
Alice Carlotti
- [PATCH 2/2] Regenerated files for FEAT_LSCP
Alice Carlotti
- [PATCH v2] RISC-V: Check if the merged ISA string is conflicting
Yu-Cheng Liang
- [PATCH v3 00/12] Add support for LoongArch32 in Binutils
mengqinggang
- unsubscribe
Thomas Richter
- [PATCH v5] PowerPC: Support for SHA2 and SHA3 Compute Instructions (RFC02654)
Abhay Kandpal
- [PATCH] gas/d30v: make use of tc_symbol_chars[]
Jan Beulich
- [PATCH] bfd: correct dir separator conversion for Win32
Jan Beulich
- [PATCH v3] PowerPC: Support for Elliptic Curve Cryptography Acceleration Instructions (RFC02669)
Abhay Kandpal
- [PATCH] ld/MIPS: use distinguishable "section ordering test" names
Jan Beulich
- [PATCH v2 0/3] aarch64: Add support for POE2 extension.
Srinath Parvathaneni
- [PATCH] RISC-V: avoid ld crashes due to bogus use by testcases
Jan Beulich
- [PATCH 0/3] avoid gcc extension using __VA_ARGS__
Jan Beulich
- [PATCH v0] aarch64: silence GCS warnings on shared libraries for -z gcs=implicit
Matthieu Longo
- [PATCH] bfd: fix build with C23
Guinevere Larsen
- [PATCH] elf: Add SHT_SUNW_ctf and SHT_SUNW_symnsort
H.J. Lu
- [PATCH] bfd/ELF: Handle prstatus of 156 bytes in elf32_arm_nabi_grok_prstatus
Luis
- [PATCH] i386: Add GLIBC_ABI_GNU_TLS dependency only if used
H.J. Lu
- [PATCH v2] bfd: Add minimal support to handle note that describes xsave layout
Balasubrmanian, Vignesh
- PR 33697, fuzzer segfault
Alan Modra
- PR 33698 and PR 33700
Alan Modra
- PR 33701, abort in byte_get_little_endian
Alan Modra
- [PATCH v3] bfd: Add minimal support to handle note that describes xsave layout
Vignesh Balasubramanian
- [PATCH v2] aarch64: Add support for new BTI <target> "r".
Srinath Parvathaneni
- [PATCH] ld/pe-dll: Don't auto-export symbols from .tls section
LIU Hao
- Commit: Fix typo in aarch64-opc.c
Nick Clifton
- [PATCH v6 0/5] Objdump: New feature display of global variable info based on DWARF info section
Guillaume VACHERIAS - foss
- [PATCH v2] aarch64: Add support for FEAT_LSCP.
richard.ball@arm.com
- [PATCH] x86: Add _bfd_elf_x86_copy_special_section_fields
H.J. Lu
- ☝ Buildbot (Sourceware): binutils-gdb - worker not available (master)
builder@sourceware.org
- lto-wrapper warning note
Alan Modra
- [PATCH] RISC-V: Add SpacemiT vendor extensions xsmtvdot
Mark Zhuang
- [PATCH] ld: Remove elf_i386/elf_x86_64 for Solaris x86 targets
H.J. Lu
- [PATCH, V2 00/14] sframe: some refactoring and misc improvements
Indu Bhagat
- [PATCH, V2 01/14] Revert "gas: Don't skip SFrame FDE if .cfi_register specifies RA w/o tracking"
Indu Bhagat
- [PATCH, V2 02/14] gas: sframe: testsuite: add testcase for .cfi_register RA
Indu Bhagat
- [PATCH, V2 03/14] gas: sframe: ignore .cfi_offset for RA selectively
Indu Bhagat
- [PATCH, V2 04/14] include: gas: bfd: sframe: clean the abstraction
Indu Bhagat
- [PATCH, V2 05/14] libsframe: implement an internal-only SFrame FDE representation
Indu Bhagat
- [PATCH, V2 06/14] include: sframe: add SFRAME_V2_ prefixed macro names for FDE
Indu Bhagat
- [PATCH, V2 07/14] gas: libsframe: use SFRAME_V2_* macro where available
Indu Bhagat
- [PATCH, V2 08/14] gas: sframe: add new sframe_xlate_ctx_get_cur_cfa_reg
Indu Bhagat
- [PATCH, V2 09/14] gas: sframe: pass SFrame FDE as argument to output_sframe_row_entry
Indu Bhagat
- [PATCH, V2 10/14] gas: sframe: refactor out the offsets emission code
Indu Bhagat
- [PATCH, V2 11/14] libsframe: refactor sframe_decoder_add_funcdesc for internal use
Indu Bhagat
- [PATCH, V2 12/14] libsframe: use tmp variable for realloc pattern
Indu Bhagat
- [PATCH, V2 13/14] libsframe: refactor out sframe_fre_grow_tbl
Indu Bhagat
- [PATCH, V2 14/14] gas: sframe: rename "bp" to "fp"
Indu Bhagat
- [RFC 00/28] SFrame V3 patchset
Indu Bhagat
- bitwise operation between different enumeration types
Alan Modra
- gold testsuite volatile fixes
Alan Modra
- tail recursion in _bfd_elf_link_hide_symbol
Alan Modra
- [PING^2][PATCH v4 0/1] Add bigobj support to AArch64 COFF
Evgeny Karpov
- [PATCH v3 00/10] mips hi16/lo16 reloc handling
Maciej W. Rozycki
- [PATCH v3 06/18] LD/testsuite: Expand archive verification to group feature
Jan Beulich
- [PATCH v3 07/18] BFD: Make file offset unsigned in archive symbols
Jan Beulich
- [PATCH v3 09/18] BFD: Prevent a crash on freeing a BFD's uninitialized section hash
Jan Beulich
- [PATCH v3 10/18] BFD: Unset the format on releasing a BFD's objalloc memory
Jan Beulich
- [PATCH v3 11/18] BFD: Correct archive format determination for non-default link emulations
Jan Beulich
- [PATCH v3 12/18] PR ld/24600: BFD: Add general linker support for mapless archives
Jan Beulich
- [PATCH v3 13/18] PR ld/24600: LD: Add options to control mapless archive acceptance
Jan Beulich
- [PATCH v3 08/18] BFD: Add BFD pointer member to `struct carsym'
Jan Beulich
- [PATCH v3 14/18] LD: Guard `new_afile' result with assertions
Jan Beulich
- [PATCH v3 15/18] LD: Factor out new input file node insertion
Jan Beulich
- [PATCH v3 16/18] BFD: Add BFD pointer member to archive member references
Jan Beulich
- [PATCH v3 17/18] PR ld/24600: BFD: Add general linker support for fake archives
Jan Beulich
- [PATCH v10 08/28] bfd: write Object Attributes v2
Jan Beulich
- [PATCH v10 09/28] readelf: dump Object Attributes v2
Jan Beulich
- [PATCH v10 11/28] bfd: parse Object Attributes v2's section in input object files
Jan Beulich
- [PATCH v10 12/28] bfd: add support for copying Object Attributes v2
Jan Beulich
- [PATCH v3 02/44] bfd: add intelgt target to BFD
Simon Marchi
- [PATCH v3 00/44] A new target to debug Intel GPUs
Simon Marchi
- Monthly GNU Toolchain office hours Asia Timezone.
Ramana Radhakrishnan
- ☠ Buildbot (Sourceware): binutils-gdb - failed update (failure) (master)
builder@sourceware.org
- ☺ Buildbot (Sourceware): binutils-gdb - build successful (master)
builder@sourceware.org
- [PATCH v10 14/28] OAv2 merge: plumbing of generic merge logic during linkage
Jan Beulich
- [PATCH v10 15/28] OAv2 merge: find first input containing an object attributes section
Jan Beulich
- [PATCH v10 16/28] OAv2 merge: create a section for object attributes
Jan Beulich
- [PATCH v10 17/28] OAv2 merge: merge subsections and tags at file scope
Jan Beulich
- [PATCH v10 18/28] OAv2 merge: mark unknown subsections
Jan Beulich
- [PATCH v10 20/28] OAv2 merge: prune unsupported or invalid subsections and attributes
Jan Beulich
- [PATCH v10 21/28] OAv2 merge: translate GNU properties to Object Attributes v2 (and vice versa)
Jan Beulich
- [PATCH v4 0/1] FEAT_SVE2p3 and FEAT_SME2p3: updates following review feedback
Sivan Shani
- [PATCH] AArch64: Add FEAT_SVE2p3 and FEAT_SME2p3 instructions.
Sivan Shani
- [PATCH v4] Add .clang-format
Tom Tromey
- Question about gprofng
Abdurrahman Akin
- [PATCH] aarch64: Add system registers for Virtual Tagging Extension
Alice Carlotti
- [COMMITTED, PATCH] lto: Compile LTO 15 test with -fno-fat-lto-objects
H.J. Lu
- [PATCH] aarch64: Update parse_vector_reg_list comment
Alice Carlotti
- [PATCH v2] ld/pe-dll: Don't auto-export symbols from .tls section
LIU Hao
- [PATCH v3] ld/pe-dll: Don't auto-export symbols from .tls section
LIU Hao
- [PATCH v4] ld/pe-dll: Don't auto-export symbols from .tls section
LIU Hao
- [PATCH v3] aarch64: Add support for new BTI <target> "r"
Srinath Parvathaneni
- [PATCH] LoongArch: Set the default ABI for the loongarch*-elf target
Lulu Cai
- ☠ Buildbot (Sourceware): binutils-gdb - failed test (failure) (master)
builder@sourceware.org
- [PATCH] ld: Remove elf_i386_ldso reference
Rainer Orth
- [PATCH v2] LoongArch: Set the default ABI for the loongarch*-elf target
Lulu Cai
- [PATCH] x86/Solaris: address two ld test FAILs
Jan Beulich
- [PATCH v3] LoongArch: Set the default ABI of loongarch*-elf targets to double-float
Lulu Cai
- Sourceware Open Office Now
Mark Wielaard
- ☠ Buildbot (Sourceware): binutils-gdb-autoregen - failed 'git diff ...' (failure) (master)
builder@sourceware.org
- [commit] Fix configure rebuild
John David Anglin
- [PATCH v1] LoongArch: Add disassembly support for ud ui5
Lulu Cai
- Ping: [PATCH] libiberty/testsuite: make test-pexecute's -t option a little more useful
Jan Beulich
- [PATCH] gas/x86: reduce / correct target checks for --64 command line option
Jan Beulich
- [PATCH] ld/ELF: suppress note section rearrangement for relocatable linking
Jan Beulich
- [PATCH] ELF: give .note.GNU-stack proper section type
Jan Beulich
- [PATCH 0/4] bfd/ELF: restrict extended feature support code to where it's actually used
Jan Beulich
- [PATCH] gas: stub out sframe-opt.c functions when SFrame is not supported
Jan Beulich
- [PING][PATCH] RISC-V: Add SpacemiT vendor extensions xsmtvdot
Mark Zhuang
- [PATCH v3 05/18] CRIS/LD/testsuite: Add tests for emulation switching
Maciej W. Rozycki
- LoongArch: Add linker relaxation support for R_LARCH_CALL30
Alan Modra
- [PATCH v3 0/4] aarch64: Add support for POE2 extension.
Srinath Parvathaneni
- [PATCH v5 0/1] AArch64: Add FEAT_SVE2p3 and FEAT_SME2p3 instructions.
Sivan Shani
- [COMMITTED] gas: sframe: fix memory leak of remember_fre
Indu Bhagat
- [PATCH] bfd: include: sframe: fix PR ld/32789
Indu Bhagat
- [PATCH v6] AArch64: Add FEAT_SVE2p3 and FEAT_SME2p3 instructions.
Sivan Shani
- [PATCH v4 0/4] aarch64: Add support for POE2 extension.
Srinath Parvathaneni
- [PING v2] [PATCH v2 00/15] Integrate MIPS-Specific Support
Jovan Dmitrovic
- [PATCH 1/1] AArch64: Add FEAT_F16F32DOT instructions
Alice Carlotti
- Reminder - GNU Toolchain Office Hours Asia timezone 18 December 9 a.m. India time.
Ramana Radhakrishnan
- [PATCH v2] AArch64: Add FEAT_F16F32DOT instructions
Sivan Shani
- [PATCH v2] AArch64: Add FEAT_F16F32MM
Sivan Shani
- [PATCH v2] AArch64 v9.7 extensions: FEAT_F16MM
Sivan Shani
- [PATCH v2] AArch64 v9.7 extensions: FEAT_SVE_B16MM
Sivan Shani
- [PATCH v2 0/2] aarch64: Add FEAT_MOPS_GO instructions
Yury Khrustalev
- [PATCH] gas/CFI: fix .cfi_escape parsing when equates are in use
Jan Beulich
- PING: [PATCH 0/7] RISC-V: Add support for Andes floating-point and vector extensions
Ethan Y. C. Liang
- [PATCH v10 19/28] OAv2 merge: merging Object Attributes
Jan Beulich
- [PATCH v10 23/28] aarch64: merge of Object Attributes v2 during linkage
Jan Beulich
- [PATCH v10 25/28] gnu directives: add support for .gnu_attribute and .gnu_subsection in OAv2 context
Jan Beulich
- [PATCH v10 26/28] gnu directives: gas/readelf tests for gnu attributes v2
Jan Beulich
- [PATCH] Sync config.guess and config.sub with latest versions from the config project
Tankut Baris Aktemur
- asan: alpha-vms: mmember access within null pointer
Alan Modra
- [aarch64] Fix misplaced synthetic plt syms
Richard Earnshaw
- PR 27666, bfd_check_format_matches
Alan Modra
- ☠ Buildbot (Sourceware): binutils-snapshots - failed './src-release.sh -x ...' (failure) 'mkdir -p ...' (failure) (master)
builder@sourceware.org
- More Forge, More Actions, More Infrastructure
Mark Wielaard
- [LD] Which entry in ldlex.l matches "current pointer", the dot
Zheng Bao
- [PATCH v1] loongarch: add back support for object attributes v1
Matthieu Longo
- [PATCH v1] gas: add as_info() for informational diagnostics
Matthieu Longo
- [COMMITTED] binutils gdb snapshots, don't create xz src-release archives, used gz
Mark Wielaard
- [RFC] RISC-V: Added draft Zvzip extension with v0.1
Nelson Chu
- [PATCH] LoongArch: add "b{eq, ne}z" as an alias for "b{eq, ne}" on LA32R
Lulu Cai
- [PATCH v2] gas: add as_info() for informational diagnostics
Matthieu Longo
- [PATCH v1] aarch64: silence GCS warnings on shared libraries for -z gcs=implicit
Matthieu Longo
- [PATCH 0/2] x86: optimize MOV{S,Z}X in a few cases
Jan Beulich
- [PATCH v5 0/4] aarch64: Add support for POE2 extension
Srinath Parvathaneni
- [PATCH] RISC-V: PR30237, don't add PT_RISCV_ATTRIBUTES in objcopy/strip
Sungjoon Moon
- PR 33726, symbols in excluded sections
Alan Modra
- [PATCH] ELF: Properly copy and strip Solaris binaries
H.J. Lu
- [PATCH] c6x: fix unwinding instructions for some values of cfa_offset
Richard Braun
- [PATCH] bfd: Re-enable 64-bit support for 32-bit Solaris targets
Rainer Orth
- [V1 00/36] SFrame V3 patchset
Indu Bhagat
- [committed 1/4] aarch64: Fix luti2/luti4 decode mask
Alice Carlotti
- [committed 2/4] aarch64: Accept .b/.h/.s in movaz (array to vector)
Alice Carlotti
- [committed 3/4] aarch64: Remove a space from movaz za operand
Alice Carlotti
- [committed 4/4] aarch64: Remove sme2_movaz instruction class
Alice Carlotti
- [PATCH v11 00/25] AArch64 AEABI build attributes (a.k.a. object attributes v2)
Matthieu Longo
- New Malay PO file for 'bfd' (version 2.44.90)
Translation Project Robot
- [PATCH v6 0/4] aarch64: Add support for POE2 extension
Srinath Parvathaneni
Last message date:
Wed Dec 31 19:12:38 GMT 2025
Archived on: Wed Dec 31 19:14:39 GMT 2025
This archive was generated by
Pipermail 0.09 (Mailman edition).