libffi Darwin support

Bryce McKinlay bryce@waitaki.otago.ac.nz
Tue Nov 27 17:18:00 GMT 2001


David Edelsohn wrote:

>	As was mentioned in the posting on libffi-discuss last January,
>this is the same ABI as AIX (except for the lack of 64-bit support).  I am
>disappointed that it was added with the name Darwin all over the place,
>

Do you have any suggestions for a more generic name for this ABI? 
Calling it ffi_aix probibly isn't much better ;-)

>Also, the ABI description of long double is incorrect.  128-bit
>long double is returned in registers fp1 and fp2, not as a structure with
>a hidden parameter. 
>

This is what the docs say, but is it what Darwin GCC really implements? 
The long double test in ffitest.c works for me on darwin with the 
existing code.

>I am not sure if the use of fp2 needs to be marked somehow.
>

I think the assembly code would need to also save fp2 into the 
caller-provided return value area at r30 in the long double case?

regards

Bryce.




More information about the Libffi-discuss mailing list