libffi Darwin support
John Hörnkvist
john@toastedmarshmallow.com
Tue Nov 27 20:28:00 GMT 2001
On Wednesday, November 28, 2001, at 05:15 , David Edelsohn wrote:
> John> Two questions, then:
> John> What is the proper name of the ABI?
>
> The ABI really is called the AIX ABI. There is a descendant
> called the PowerOpen ABI which changed a few things, but neither AIX nor
> Darwin follow the PowerOpen ABI.
Well, then my vote is for changing Darwin to AIX_ABI where Darwin refers
to the API and not the OS.
> John> Are you able to test that your changes don't break on Darwin/Mac
> OS X?
>
> I am not changing anything, unless we try to merge the two
> assembly files. The only thing I might want to change in ffi_darwin.c
> is
> to use sizeof(long) instead of sizeof(int) for stack offsets.
Sounds good.
/John
--
ToastedMarshmallow, the perfect Cocoa companion
http://www.toastedmarshmallow.com
More information about the Libffi-discuss
mailing list