libffi Darwin support

David Edelsohn dje@watson.ibm.com
Tue Nov 27 19:35:00 GMT 2001


>>>>> Bryce McKinlay writes:

Bryce> Do you have any suggestions for a more generic name for this ABI? 
Bryce> Calling it ffi_aix probibly isn't much better ;-)

	I was going to mention "not ffi_aix", but I thought that would be
obvious.

Bryce> This is what the docs say, but is it what Darwin GCC really implements? 
Bryce> The long double test in ffitest.c works for me on darwin with the 
Bryce> existing code.

	GCC does not provide *any* 128-bit long double support for
PowerPC.  I currently am implementing it based on the correct ABI.

David



More information about the Libffi-discuss mailing list