[PATCH 1/7] support: Clean up NSS formatting and checking functions

Florian Weimer fweimer@redhat.com
Mon Feb 2 19:52:58 GMT 2026


* DJ Delorie:

> The syntactic changes look OK but this part concerns me:
>
> We have a support/check_nss.h
>
> We want to add support_check_nss()
>
> Why create support/support_check_nss.h when we already have
> support/check_nss.h?

These functions are old and therefore do not have the support_ prefix
yet.  The support_check_nss function is kind of separate from the rest,
so I used a different naming pattern.  The new file is called
support/support_check_nss.c to match the function name.

I can rename all the functions if you'd prefer that.

Thanks,
Florian



More information about the Libc-alpha mailing list