The syntactic changes look OK but this part concerns me: We have a support/check_nss.h We want to add support_check_nss() Why create support/support_check_nss.h when we already have support/check_nss.h?