[PATCH 1/7] support: Clean up NSS formatting and checking functions
DJ Delorie
dj@redhat.com
Mon Feb 2 20:40:59 GMT 2026
Florian Weimer <fweimer@redhat.com> writes:
> These functions are old and therefore do not have the support_ prefix
> yet. The support_check_nss function is kind of separate from the rest,
> so I used a different naming pattern. The new file is called
> support/support_check_nss.c to match the function name.
I was more concerned with the confusion behind having the two similarly
named files.
Have support/check-nss.h or support/support-check-nss.h but not both.
We already do "#include <support/...>" in the files, we don't NEED the
headers to have the support_ part in the base name.
For .c files the argument is a little different if you want one file per
function (I'll argue against that in 2/7). Headers typically cover
whole categories, not just one function, so need not be named after the
functions.
More information about the Libc-alpha
mailing list