[RFC PATCH v4 1/2] configure: Remove --enable-obsolete-nsl

Florian Weimer fweimer@redhat.com
Tue Jun 30 17:23:44 GMT 2020


* Petr Vorel:

>> nss_compat no longer depends on libnsl in current glibc.  It can be used
>> without NIS, and some users do that.  I don't think your patch changes
>> this.

> Interesting. I guess adding this would be worth then:
> libnss_compat no longer depends on libnsl and can be used without NIS.

We made this change a while back, in glibc 2.27, when the sources were
moved to nss/nss_compat (from nis/nss_compat).  So this isn't something
new.

Thanks,
Florian



More information about the Libc-alpha mailing list