vector, matrix copy

Brian Gough
Wed Mar 1 03:04:00 GMT 2000

There is a dilemma here. GSL is designed to follow Std C-library
conventions, e.g.  memcpy (dest, src)  <==> gsl_vector_cpy (dest, src)

For readability it would be preferable to use _copy instead of _cpy,
However that would suggest swapping the arguments, e.g. copy(from,to)
as in the C++ STL or Unix cp, which breaks the C-style.

What used to be implemented was inconsistent -- the name _copy with
the arguments (dest, src). 

I am open to suggestions on this (gsl_vector_memcpy , ...?).

Steve ROBBINS writes:
 > On Tue, 29 Feb 2000, Thomas Walter wrote:
 > > Hello,
 > > there was recently a name change from 'gsl_vector_copy' to
 > > 'gsl_vector_cpy'.
 > Really?  Why wld flks wnt to mak it hrdr to rd th src cde?
 > -S

More information about the Gsl-discuss mailing list