inferior_pid's magic value of zero.

Kevin Buettner kevinb@cygnus.com
Sun Mar 25 09:10:00 GMT 2001


On Mar 25, 11:46am, Fernando Nasser wrote:

> Todd Whitesel wrote:
> > 
> > Would anyone object to patches that used a macro (say, NO_INFERIOR) instead
> > of the magic 0 that is currently used ?
> > 
> > Assuming the answer is yes, presumably we'd put the default #define to 0 in
> > inferior.h, and allow it to be overridden by tm.h.
> > 
> 
> What about a multi-arch NO_INFERIOR that can be defined as a function in
> you *-tdep code?
> 
> The default would be   (iferior_pid == 0)

FYI, my yet to be applied ptid patches have a null_ptid object.


More information about the Gdb mailing list