inferior_pid's magic value of zero.

Todd Whitesel toddpw@windriver.com
Thu Mar 29 16:27:00 GMT 2001


>>> Would anyone object to patches that used a macro (say, NO_INFERIOR) instead
>>> of the magic 0 that is currently used ?
>> What about a multi-arch NO_INFERIOR that can be defined as a function in
>> you *-tdep code?
>> The default would be   (iferior_pid == 0)
> 
> FYI, my yet to be applied ptid patches have a null_ptid object.

If this means we switch to testing a pointer versus NULL, then that sounds
best. PID's really should be opaque objects, as most of GDB just needs to
pass them around and test them for validity -- only the tdep code should
be allowed to create/destroy/interpret one.

-- 
Todd Whitesel
toddpw @ windriver.com


More information about the Gdb mailing list