inferior_pid's magic value of zero.

Fernando Nasser fnasser@redhat.com
Sun Mar 25 08:49:00 GMT 2001


Todd Whitesel wrote:
> 
> Would anyone object to patches that used a macro (say, NO_INFERIOR) instead
> of the magic 0 that is currently used ?
> 
> Assuming the answer is yes, presumably we'd put the default #define to 0 in
> inferior.h, and allow it to be overridden by tm.h.
> 

What about a multi-arch NO_INFERIOR that can be defined as a function in
you *-tdep code?

The default would be   (iferior_pid == 0)

-- 
Fernando Nasser
Red Hat Canada Ltd.                     E-Mail:  fnasser@redhat.com
2323 Yonge Street, Suite #300
Toronto, Ontario   M4P 2C9


More information about the Gdb mailing list