This is the mail archive of the mailing list for the glibc project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Requiring Linux 3.2 for glibc 2.24

On Thursday 11 February 2016 10:14:07 Florian Weimer wrote:
> On 02/11/2016 09:54 AM, Dmitry Mishin wrote:
> >> On 02/09/2016 03:54 PM, Florian Weimer wrote:
> But if this is correct, not much will change from an OpenVZ point of
> view if we gradually increase the minimum kernel version required by
> glibc upstream.  True, future Fedora versions will require a newer
> kernel version.  But the Fedora glibc will have the same kernel
> requirements as other distributions which already pass
> --enable-kernel=3.2.0 or --enable-kernel=3.10.0 at glibc configure time,
> so that will not cause any additional problems to you over what you have
> to deal with today.

For references, current Fedora Rawhide builds glibc with --enable-kernel=2.6.32:
# This is to ensure that __frame_state_for is exported by glibc
# will be compatible with egcs 1.x.y
BuildRequires: gcc >= 3.2
%define enablekernel 2.6.32
Conflicts: kernel < %{enablekernel}
%define target %{_target_cpu}-redhat-linux

Debian uses 3.2 on all architectures except x86-32 and x86-64, which use
2.6.32, from
./sysdeps/ := 3.2
./sysdeps/ := 2.6.32
./sysdeps/ := 2.6.32
./debian/sysdeps/ = --with-headers=$(shell pwd)/debian/include --enable-kernel=$(call xx,MIN_KERNEL_SUPPORTED)

Ubuntu seems to have an older version of same package and uses 2.6.32
for all architectures, from
./sysdeps/ := 2.6.32

OpenSUSE Tumbleweed uses 3.0, see
./glibc.spec:%define enablekernel 3.0
./glibc.spec:           --enable-kernel=%{enablekernel} \

Arch Linux uses 2.6.32, see
      --enable-kernel=2.6.32 \

Gentoo doesn't seem to pass any minimum kernel version:


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]