This is the mail archive of the
mailing list for the glibc project.
Re: [PATCH] locks: rename file-private locks to file-description locks
- From: "Michael Kerrisk (man-pages)" <mtk dot manpages at gmail dot com>
- To: Jeff Layton <jlayton at redhat dot com>, Rich Felker <dalias at libc dot org>
- Cc: mtk dot manpages at gmail dot com, linux-fsdevel at vger dot kernel dot org, linux-kernel at vger dot kernel dot org, samba-technical at lists dot samba dot org, Ganesha NFS List <nfs-ganesha-devel at lists dot sourceforge dot net>, Carlos O'Donell <carlos at redhat dot com>, libc-alpha <libc-alpha at sourceware dot org>, "Stefan (metze) Metzmacher" <metze at samba dot org>, Christoph Hellwig <hch at infradead dot org>
- Date: Mon, 21 Apr 2014 20:18:50 +0200
- Subject: Re: [PATCH] locks: rename file-private locks to file-description locks
- Authentication-results: sourceware.org; auth=none
- References: <1398087935-14001-1-git-send-email-jlayton at redhat dot com> <20140421140246 dot GB26358 at brightrain dot aerifal dot cx> <535529FA dot 8070709 at gmail dot com> <20140421161004 dot GC26358 at brightrain dot aerifal dot cx> <20140421124508 dot 4f2c9ca7 at tlielax dot poochiereds dot net>
On 04/21/2014 06:45 PM, Jeff Layton wrote:
> On Mon, 21 Apr 2014 12:10:04 -0400
> Rich Felker <email@example.com> wrote:
>> On Mon, Apr 21, 2014 at 04:23:54PM +0200, Michael Kerrisk (man-pages) wrote:
>>> On 04/21/2014 04:02 PM, Rich Felker wrote:
>>>> On Mon, Apr 21, 2014 at 09:45:35AM -0400, Jeff Layton wrote:
>>> initial preference, and I also suggested "file-description locks"
>>> and noted the drawbacks of that term. I think it's insufficient
>>> to say "stick with the existing poor name"--if you have
>>> something better, then please propose it. (Note by the way
>>> that for nearly a decade now, the open(2) man page has followed
>>> POSIX in using the term "open file description. Full disclosure:
>>> of course, I'm responsible for that change in the man page.)
>> I'm well aware of that. The problem is that the proposed API is using
>> the two-letter abbreviation FD, which ALWAYS means file descriptor and
>> NEVER means file description (in existing usage) to mean file
>> description. That's what's wrong.
> Fair enough. Assuming we kept "file-description locks" as a name, what
> would you propose as new macro names?
I assume you meant, "assume we kept the term 'file-private locks'..."
In that case, at least make the constants something like
so that they are not confused with the traditional constants.
Linux man-pages maintainer; http://www.kernel.org/doc/man-pages/
Linux/UNIX System Programming Training: http://man7.org/training/