This is the mail archive of the
mailing list for the glibc project.
Re: [PATCH] locks: rename file-private locks to file-description locks
- From: Andy Lutomirski <luto at amacapital dot net>
- To: Jeff Layton <jlayton at redhat dot com>, Rich Felker <dalias at libc dot org>
- Cc: libc-alpha <libc-alpha at sourceware dot org>, Carlos O'Donell <carlos at redhat dot com>, samba-technical at lists dot samba dot org, linux-kernel at vger dot kernel dot org, "Stefan (metze) Metzmacher" <metze at samba dot org>, "Michael Kerrisk (man-pages)" <mtk dot manpages at gmail dot com>, linux-fsdevel at vger dot kernel dot org, Ganesha NFS List <nfs-ganesha-devel at lists dot sourceforge dot net>
- Date: Mon, 21 Apr 2014 11:01:20 -0700
- Subject: Re: [PATCH] locks: rename file-private locks to file-description locks
- Authentication-results: sourceware.org; auth=none
- References: <1398087935-14001-1-git-send-email-jlayton at redhat dot com> <20140421140246 dot GB26358 at brightrain dot aerifal dot cx> <535529FA dot 8070709 at gmail dot com> <20140421161004 dot GC26358 at brightrain dot aerifal dot cx> <20140421124508 dot 4f2c9ca7 at tlielax dot poochiereds dot net>
On 04/21/2014 09:45 AM, Jeff Layton wrote:
> On Mon, 21 Apr 2014 12:10:04 -0400
> Rich Felker <email@example.com> wrote:
>> I'm well aware of that. The problem is that the proposed API is using
>> the two-letter abbreviation FD, which ALWAYS means file descriptor and
>> NEVER means file description (in existing usage) to mean file
>> description. That's what's wrong.
> Fair enough. Assuming we kept "file-description locks" as a name, what
> would you propose as new macro names?
If you said "file description" to me, I'd assume you made a typo. If,
on the other hand, you said "open file" or "open file description" or,
ugh, "struct file", I think I'd understand.