This is the mail archive of the
mailing list for the glibc project.
Re: [PATCH] locks: rename file-private locks to file-description locks
- From: Rich Felker <dalias at libc dot org>
- To: Jeff Layton <jlayton at redhat dot com>
- Cc: linux-fsdevel at vger dot kernel dot org, linux-kernel at vger dot kernel dot org, samba-technical at lists dot samba dot org, Ganesha NFS List <nfs-ganesha-devel at lists dot sourceforge dot net>, Carlos O'Donell <carlos at redhat dot com>, libc-alpha <libc-alpha at sourceware dot org>, "Stefan (metze) Metzmacher" <metze at samba dot org>, Michael Kerrisk <mtk dot manpages at gmail dot com>
- Date: Mon, 21 Apr 2014 10:02:46 -0400
- Subject: Re: [PATCH] locks: rename file-private locks to file-description locks
- Authentication-results: sourceware.org; auth=none
- References: <1398087935-14001-1-git-send-email-jlayton at redhat dot com>
On Mon, Apr 21, 2014 at 09:45:35AM -0400, Jeff Layton wrote:
> File-private locks have been merged into Linux for v3.15, and *now*
> people are commenting that the name and macro definitions for the new
> file-private locks suck.
> ....and I can't even disagree. The names and command macros do suck.
> We're going to have to live with these for a long time, so it's
> important that we be happy with the names before we're stuck with them.
> The consensus on the lists so far is that they should be rechristened as
> "file-description locks".
> This patch makes the following changes that I think are necessary before
> v3.15 ships:
> 1) rename the command macros to their new names. These end up in the uapi
> headers and so are part of the external-facing API. It turns out that
> glibc doesn't actually use the fcntl.h uapi header, but it's hard to
> be sure that something else won't. Changing it now is safest.
> 2) make the the /proc/locks output display these as type "FDLOCK"
> The rest of the renaming can wait until v3.16, since everything else
> isn't visible outside of the kernel.
I'm sorry I didn't chime in on this earlier, but I really prefer the
(somewhat bad) current naming ("private") to the
ridiculously-confusing use of "FD" to mean "file descriptION" when
everybody is used to it meaning "file descriptOR". The potential for
confusion that these are "file descriptOR locks" (they're not) is much
more of a problem, IMO, than the confusion about what "private" means
(since it doesn't have an established meaning in this context.
Thus my vote is for leaving things the way the kernel did it already.