Bug 25010 - Calls to error () can cause SIGTTOU to send gdb to the background.
Summary: Calls to error () can cause SIGTTOU to send gdb to the background.
Status: RESOLVED FIXED
Alias: None
Product: gdb
Classification: Unclassified
Component: gdb (show other bugs)
Version: 8.3
: P2 normal
Target Milestone: 8.3.1
Assignee: Not yet assigned to anyone
URL:
Keywords:
: 25015 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-09-18 14:13 UTC by Tom de Vries
Modified: 2019-10-13 13:09 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tom de Vries 2019-09-18 14:13:21 UTC
Calls to error () can cause SIGTTOU to send gdb to the background.
    
For example, on an Arm build:
(gdb) b main
Breakpoint 1 at 0x10774: file /build/gdb/testsuite/../../../src/binutils-gdb/gdb/testsuite/gdb.base/watchpoi
nt.c, line 174.
(gdb) r
Starting program: /build/gdb/testsuite/outputs/gdb.base/watchpoint/watchpoint
    
[1]+  Stopped                 ../gdb ./outputs/gdb.base/watchpoint/watchpoint
localhost$ fg
../gdb ./outputs/gdb.base/watchpoint/watchpoint
Cannot parse expression `.L1199 4@r4'.
warning: Probes-based dynamic linker interface failed.
Reverting to original interface.
Comment 1 Tom de Vries 2019-09-18 14:13:46 UTC
Fixed on master by commit 766f883622 "Suppress SIGTTOU when handling errors".
Comment 2 cvs-commit@gcc.gnu.org 2019-09-18 14:21:08 UTC
The gdb-8.3-branch branch has been updated by Tom de Vries <vries@sourceware.org>:

https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;h=5ca0b868fa7f767788555b3c32d8931017c0d756

commit 5ca0b868fa7f767788555b3c32d8931017c0d756
Author: Tom de Vries <tdevries@suse.de>
Date:   Wed Sep 18 16:20:25 2019 +0200

    Update ChangeLog entry of commit 8ac39635f6 and mention PR gdb/25010
Comment 3 Tom de Vries 2019-09-18 14:22:38 UTC
Fix backported, marking resolved-fixed.
Comment 4 Alan Hayward 2019-09-19 14:39:28 UTC
*** Bug 25015 has been marked as a duplicate of this bug. ***
Comment 5 cvs-commit@gcc.gnu.org 2019-10-13 13:09:50 UTC
The master branch has been updated by Tom de Vries <vries@sourceware.org>:

https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;h=68255adc03d3256af140432213c8ae136f16e419

commit 68255adc03d3256af140432213c8ae136f16e419
Author: Tom de Vries <tdevries@suse.de>
Date:   Sun Oct 13 15:09:09 2019 +0200

    Mention PR gdb/25010 in ChangeLog entry
    
    [ Port of gdb-8.3-branch commit 5ca0b868fa7 "Update ChangeLog entry of commit
    8ac39635f6 and mention PR gdb/25010". ]