Bug 25015 - GDB errors can cause GDB to go into the background
Summary: GDB errors can cause GDB to go into the background
Status: RESOLVED DUPLICATE of bug 25010
Alias: None
Product: gdb
Classification: Unclassified
Component: gdb (show other bugs)
Version: 8.2
: P2 normal
Target Milestone: 8.3.1
Assignee: Alan Hayward
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-09-18 17:16 UTC by Alan Hayward
Modified: 2019-09-19 14:39 UTC (History)
0 users

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alan Hayward 2019-09-18 17:16:46 UTC
Calls to error () can cause SIGTTOU to send gdb to the background.

For example, on an Arm build:
  (gdb) b main
  Breakpoint 1 at 0x10774: file /build/gdb/testsuite/../../../src/binutils-gdb/gdb/testsuite/gdb.base/watchpoint.c, line 174.
  (gdb) r
  Starting program: /build/gdb/testsuite/outputs/gdb.base/watchpoint/watchpoint

  [1]+  Stopped                 ../gdb ./outputs/gdb.base/watchpoint/watchpoint
  localhost$ fg
  ../gdb ./outputs/gdb.base/watchpoint/watchpoint
  Cannot parse expression `.L1199 4@r4'.
  warning: Probes-based dynamic linker interface failed.
  Reverting to original interface.
Comment 1 Alan Hayward 2019-09-19 14:39:28 UTC
Already raised.

*** This bug has been marked as a duplicate of bug 25010 ***