Meaningful parameters.

Jim Kingdon kingdon@panix.com
Sun Aug 4 12:33:00 GMT 2002


> the pointer to the unit which receives the extracted material I call
> 'extractor', and when the id of the unit is needed, I've changed the
> name to 'extractor_ut' from 'u2' to disginguish the pointer from the
> unit type. Maybe 'extractor_u' would be better?

I've been using "uextractor" (don't remember if I saw that somewhere
or just made it up) but extractor_type or extractor_utype or any of
the ones don't horrify me.  Although I suppose it should be some
combination of "extractor" and "u".

Thanks for doing this work.

> I also changed 'unit3' used in the stack iteration to 'stack_unit',
> although 'stacked_unit" might be better.

I'd be tempted to call it "i" - the universal symbol for an iteration
variable.

> Thee is already some consistancy, unit pointers are almost always
> 'unit', but unit types are almost always 'u'.

Right, let's try to build on that except where it is clearly broken
(e.g. the infamous unit, unit2, unit3 case).



More information about the Xconq7 mailing list