garrison_unit?

Hans Ronne hronne@pp.sbbs.se
Fri Aug 2 10:35:00 GMT 2002


>Incidentally, the first thing I did in trying to read that code was
>rename "unit" and "unit2" to descriptive names - I'd suggest doing the
>same whenever you find code which has "unit", "unit2", and "unit3" - I
>find it is really hard to read the code if I need to keep in my head
>which one is unit3, which one is unit2, etc.

Good idea. There are some functions where units are named "occ" and
"transport" or "attacker" and "defender" but they are a minority. It would
make debugging a lot easier.

Hans

Hans Ronne

hronne@pp.sbbs.se




More information about the Xconq7 mailing list