[Bug translator/10830] new pp() variant for source-level probe point name
przemyslaw at pawelczyk dot it
sourceware-bugzilla@sourceware.org
Wed Jun 23 23:09:00 GMT 2010
------- Additional Comments From przemyslaw at pawelczyk dot it 2010-06-23 10:22 -------
(In reply to comment #3)
> pp1() is pretty obscure.
Agree.
> What about pn() for probe-name (where pp() is for probe-point)?
Sound better than "pretty please" or "people", but can be misleading.
After all the name of the probe alias is returned here.
I suggest following renames:
pp() -> ppname()
ppl() -> paname()
and leaving pp() as (deprecated) alias for new name (backward compatibility or
maybe only via --compatible).
Yes, new names would be more verbose, but also more clean IMHO. What do you
think?
--
http://sourceware.org/bugzilla/show_bug.cgi?id=10830
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.
More information about the Systemtap
mailing list