[Patch]Fix the output of argument "options" for wait4, waitpid and waitid
Cai Fei
caifei@cn.fujitsu.com
Mon Sep 3 08:27:00 GMT 2007
Hello, Frank.
Sorry for late answer.
Frank Ch. Eigler wrote:
> Cai Fei <caifei@cn.fujitsu.com> writes:
>
>
>> The system calls wait4, waitpid and waitid has an argument "int options".
>> [...]
>> and the values of WSTOPPED and WUNTRACED are equal.
>>
>
> It looks like all the matching names have matching values across the
> system calls (which makes sense). So why not just add WNOWAIT to the
> _wait4_opt_str(), and perhaps rename it to indicate that it accepts a
> union of all the wait* options?
>
Is there any misunderstanding? I can not get your meaning. WNOWAIT
already exists in
_wait4_opt_str() before the adding of _waitid_opt_str().
More information about the Systemtap
mailing list