[Patch]Fix the output of argument "options" for wait4, waitpid and waitid

Frank Ch. Eigler fche@redhat.com
Wed Aug 29 08:30:00 GMT 2007


Cai Fei <caifei@cn.fujitsu.com> writes:

> The system calls wait4, waitpid and waitid has an argument "int options".
>[...]
> and the values of WSTOPPED and WUNTRACED are equal.

It looks like all the matching names have matching values across the
system calls (which makes sense).  So why not just add WNOWAIT to the
_wait4_opt_str(), and perhaps rename it to indicate that it accepts a
union of all the wait* options?

- FChE



More information about the Systemtap mailing list