patch for module function probe

bibo mao bibo_mao@linux.intel.com
Mon Apr 3 09:24:00 GMT 2006


If it is designed feature, then kernel.function("foo") will be regarded 
as module("kernel").function("foo").  But if there is one module named 
"kernel.ko", how to probe its function although its module name is 
weird?  In another way to say what is the meaning of 
module("kernel").function("foo"), else stap manual clarify that 
module("kernel") means kernel image, user had better not use the same 
module name.


Li Guanglei wrote:
> Mao, Bibo :
>> Hi,
>>     Currently systemtap has some problem when searching module
>> function, which is reported in
>> http://sourceware.org/ml/systemtap/2006-q1/msg00674.html. Kernel is
>> treated as one module whose name is TOK_KERNEL "kernel". So this script
>> will pass to compile, it indeed will probe kernel function:
>>     probe module("kernel").function("sys_read"){
>>     }
>> But there will be problem when there is actually one module named
>> kernel.ko though its name is weird.
>>
>> Bibo,mao
>>
> Actually, I think the expansion of module("*").function("foo") into 
> kernel.function("foo") is a designed feature. It is especially useful 
> for those compiled-in kernel modules. For example, in LKET, I can use:
> 
> probe addevent.scsi.iodispatching
> = module("*").function("scsi_dispatch_cmd@drivers/scsi/scsi.c")
> 
> to let LKET work despite scsi_mod being compiled as a module or into the 
> kernel.
> 
> 
> 



More information about the Systemtap mailing list