patch for module function probe
Li Guanglei
guanglei@cn.ibm.com
Mon Apr 3 09:06:00 GMT 2006
Mao, Bibo :
> Hi,
> Currently systemtap has some problem when searching module
> function, which is reported in
> http://sourceware.org/ml/systemtap/2006-q1/msg00674.html. Kernel is
> treated as one module whose name is TOK_KERNEL "kernel". So this script
> will pass to compile, it indeed will probe kernel function:
> probe module("kernel").function("sys_read"){
> }
> But there will be problem when there is actually one module named
> kernel.ko though its name is weird.
>
> Bibo,mao
>
Actually, I think the expansion of module("*").function("foo") into
kernel.function("foo") is a designed feature. It is especially useful
for those compiled-in kernel modules. For example, in LKET, I can use:
probe addevent.scsi.iodispatching
= module("*").function("scsi_dispatch_cmd@drivers/scsi/scsi.c")
to let LKET work despite scsi_mod being compiled as a module or into
the kernel.
More information about the Systemtap
mailing list