[PATCH 5/5] libgloss: merge bfin into top-level Makefile
Corinna Vinschen
vinschen@redhat.com
Mon Feb 7 12:07:03 GMT 2022
On Feb 7 12:44, Corinna Vinschen wrote:
> On Feb 5 00:46, Mike Frysinger wrote:
> > Avoid a recursive make to speed things up a bit.
> > ---
> > libgloss/Makefile.am | 9 +
> > libgloss/Makefile.in | 342 +++++++++++++++++++++++++++++++------
> > libgloss/bfin/Makefile.in | 207 ----------------------
> > libgloss/bfin/Makefile.inc | 71 ++++++++
> > libgloss/configure | 33 +++-
> > libgloss/configure.ac | 5 +-
> > 6 files changed, 406 insertions(+), 261 deletions(-)
> > delete mode 100644 libgloss/bfin/Makefile.in
> > create mode 100644 libgloss/bfin/Makefile.inc
> > + [...]
> > +# Here is all of the development board stuff.
> > +multilibtool_DATA += \
> > + %D%/crt0.o \
> > + %D%/basiccrt.o \
> > + %D%/basiccrts.o \
> > + %D%/basiccrt561.o \
> > + %D%/basiccrt561s.o \
> > + %D%/basiccrt561b.o
> > +# %D%/basiccrt60x.o \
> > +# %D%/basiccrt60xs.o \
> > +# %D%/basiccrt60xc1.o
>
> Not sure how you guys actually building and using this stuff think about
> this, but I, for one, am a little put off by this change. The old code
> in bfin/Makefile.in had a few nice definitions like BOARD_BSP,
> BOARD_CRT0S, SIM_BSP, SIM_CRT0, etc. Why didn't you take them over?
>
> That's not saying we can't push this patch, but somehow it's losing
> readability. Now it's just a list of arbitrary files to create.
Also, what about the install-sim / install-board split? Do we know
for sure that they are not used by somebody?
Corinna
More information about the Newlib
mailing list