[PATCH 5/5] libgloss: merge bfin into top-level Makefile

Corinna Vinschen vinschen@redhat.com
Mon Feb 7 11:44:01 GMT 2022


On Feb  5 00:46, Mike Frysinger wrote:
> Avoid a recursive make to speed things up a bit.
> ---
>  libgloss/Makefile.am       |   9 +
>  libgloss/Makefile.in       | 342 +++++++++++++++++++++++++++++++------
>  libgloss/bfin/Makefile.in  | 207 ----------------------
>  libgloss/bfin/Makefile.inc |  71 ++++++++
>  libgloss/configure         |  33 +++-
>  libgloss/configure.ac      |   5 +-
>  6 files changed, 406 insertions(+), 261 deletions(-)
>  delete mode 100644 libgloss/bfin/Makefile.in
>  create mode 100644 libgloss/bfin/Makefile.inc
> 
> diff --git a/libgloss/Makefile.am b/libgloss/Makefile.am
> index 42d7b7ffb4b8..b180309ca238 100644
> --- a/libgloss/Makefile.am
> +++ b/libgloss/Makefile.am
> @@ -15,6 +15,12 @@ multilibtooldir = $(tooldir)/lib$(MULTISUBDIR)
>  multilibtool_DATA =
>  multilibtool_LIBRARIES =
>  
> +includetooldir = $(tooldir)/include
> +includetool_DATA =
> +
> +includesystooldir = $(tooldir)/include/sys
> +includesystool_DATA =
> +
>  # A fake library so automake will generate rules for plain objects that we want
>  # to install (e.g. our crt0.o objects).
>  noinst_LIBRARIES = libobjs.a
> @@ -53,6 +59,9 @@ TEXINFO_TEX = ../texinfo/texinfo.tex
>  if HAVE_DOC
>  include doc/Makefile.inc
>  endif
> +if CONFIG_BFIN
> +include bfin/Makefile.inc
> +endif
>  if CONFIG_IQ2000
>  include iq2000/Makefile.inc
>  endif
> diff --git a/libgloss/bfin/Makefile.inc b/libgloss/bfin/Makefile.inc
> new file mode 100644
> index 000000000000..35e880809a0e
> --- /dev/null
> +++ b/libgloss/bfin/Makefile.inc
> @@ -0,0 +1,71 @@
> +# Here is all of the simulator stuff.
> +multilibtool_LIBRARIES += %D%/libsim.a
> +%C%_libsim_a_SOURCES = \
> +	%D%/clear_cache_range.c \
> +	%D%/syscalls.c
> +%C%_libsim_a_CPPFLAGS = \
> +	$(AM_CPPFLAGS) \
> +	-I$(srcdir)/%D/include
> +
> +check_PROGRAMS += %D%/sim-test
> +
> +# Here is all of the development board stuff.
> +multilibtool_DATA += \
> +	%D%/crt0.o \
> +	%D%/basiccrt.o \
> +	%D%/basiccrts.o \
> +	%D%/basiccrt561.o \
> +	%D%/basiccrt561s.o \
> +	%D%/basiccrt561b.o
> +# 	%D%/basiccrt60x.o \
> +#	%D%/basiccrt60xs.o \
> +#	%D%/basiccrt60xc1.o

Not sure how you guys actually building and using this stuff think about
this, but I, for one, am a little put off by this change.  The old code
in bfin/Makefile.in had a few nice definitions like BOARD_BSP,
BOARD_CRT0S, SIM_BSP, SIM_CRT0, etc.  Why didn't you take them over?

That's not saying we can't push this patch, but somehow it's losing
readability.  Now it's just a list of arbitrary files to create.


Corinna



More information about the Newlib mailing list