[PATCH v2] Unify names of all lock objects

Freddie Chopin freddie_chopin@op.pl
Mon Jan 30 18:56:00 GMT 2017


Second version of the patch to unify names of all lock objects, which
includes Sebastian's suggestion to use better name.

All locks used by newlib (with exception of any code from sys/ folder)
follow this naming pattern: "__<name>_[recursive_]mutex".

As previously - newlib with this patch (and with fixed Thomas' patch,
which I'll send in a moment) can be compiled without issues and works

-------------- next part --------------
A non-text attachment was scrubbed...
Name: 0001-Unify-names-of-all-lock-objects.patch
Type: text/x-patch
Size: 10993 bytes
Desc: not available
URL: <http://sourceware.org/pipermail/newlib/attachments/20170130/befab451/attachment.bin>

More information about the Newlib mailing list