[PATCH] Unify names of all lock objects

Freddie Chopin freddie_chopin@op.pl
Mon Jan 30 10:38:00 GMT 2017


On Mon, 2017-01-30 at 10:42 +0100, Sebastian Huber wrote:
> On 30/01/17 10:09, Freddie Chopin wrote:
> > On Mon, 2017-01-30 at 07:55 +0100, Freddie Chopin wrote:
> > > > Alternatively I could do "__<name>_[non]recursive_lock" and
> > > > this
> > > > would
> > > > not conflict with any function name, but it's not really better
> > > > than
> > > > the "object" suffix.
> > 
> > Another option: "__<name>_[recursive_]mutex".
> 
> Yes, this is what I was about to suggest, but you were faster.

OK then, if no one objects, I'll change, test and resend the patch(es)
in the evening.

Regards,
FCh



More information about the Newlib mailing list