your patch broke darwin libffi
Bryce McKinlay
bryce@waitaki.otago.ac.nz
Fri Jan 18 19:08:00 GMT 2002
David Edelsohn wrote:
>>>>>>Bryce McKinlay writes:
>>>>>>
>
>Bryce> Wouldn't it be better to give this function the same name in both aix.S
>Bryce> and darwin.S, since only one of them gets built?
>
> I was trying to add the support with as little intrusion as
>necessary while utilizing the similarities. Darwin is not AIX and AIX is
>not Darwin. What name would you suggest? During our last discussion, no
>one could find a common name.
>
I don't see any reason why the platform/ABI name has to be in the
function name. How about simply ffi_call_inner or ffi_call_asm?
regards
Bryce.
More information about the Libffi-discuss
mailing list