[PATCH v7 1/4] Add system-wide tunables: ldconfig part
DJ Delorie
dj@redhat.com
Mon Jun 15 19:22:56 GMT 2026
Yury Khrustalev <yury.khrustalev@arm.com> writes:
>> !glibc.foo=0
>> ^ May be made more secure
>
> I think we should not do this.
Conceeded and removed.
>> +glibc.foo=0
>> ^ May be overridden
>
> If there is no prefix, does it mean the same as '+'?
Yes. I updated the docs. You really only need + when you've globally
set - and you want to override it on a per-process basis. I don't think
it's technically needed but it makes the config file much more readable.
Also, it makes the syntax "complete".
> I find the output quite difficult to understand:
I made it more readable. The extra integer was the tunable id but I
don't know how useful that would be.
>> +/* Tunable Override Policies. */
>> +typedef enum {
>> + TOP_DEFAULT = 0, /* let the internal code decide */
>> + TOP_ALLOW, /* let the environment variable override */
>
> Is there really a difference between DEFAULT and ALLOW? I think this set
> of options here makes everything more complicated than it should.
I reduced these to ALLOW and DENY, with ALLOW being the default.
I think my idea (years ago now) was to let each tunable decide what its
default should be, but I can't see how that would be realistic.
More information about the Libc-alpha
mailing list