[PATCH 2/2] clock_nanosleep.2, nanosleep.2: Use 'duration' rather than 'request'
Alejandro Colomar
alx@kernel.org
Tue Mar 5 00:34:09 GMT 2024
Hi Elliott,
On Mon, Mar 04, 2024 at 04:18:28PM -0800, enh wrote:
> thanks! https://android-review.googlesource.com/c/platform/bionic/+/2987070
> changes to
>
> /**
> * [clock_nanosleep(2)](http://man7.org/linux/man-pages/man2/clock_nanosleep.2.html)
> * sleeps for the given time (or until the given time if the TIMER_ABSTIME flag
> * is used), as measured by the given clock.
> *
> * Returns 0 on success, and returns -1 and returns an error number on failure.
> * If the sleep was interrupted by a signal, the return value will be `EINTR`
> * and `remainder` will be the amount of time remaining.
> */
> int clock_nanosleep(clockid_t __clock, int __flags, const struct
> timespec* _Nonnull __time, struct timespec* _Nullable __remainder);
Hmmmm, that's the best name, meaningfully, I think. But I've been
trying to avoid it. I don't like using names of standard functions in
identifiers; it might confuse. As an alternative, I thought of 't'.
What do you think?
Have a lovely night!
Alex
--
<https://www.alejandro-colomar.es/>
Looking for a remote C programming job at the moment.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: not available
URL: <https://sourceware.org/pipermail/libc-alpha/attachments/20240305/89d888f8/attachment-0001.sig>
More information about the Libc-alpha
mailing list