[PATCH 2/2] clock_nanosleep.2, nanosleep.2: Use 'duration' rather than 'request'
enh
enh@google.com
Tue Mar 5 00:18:28 GMT 2024
On Sun, Mar 3, 2024 at 4:55 AM Alejandro Colomar <alx@kernel.org> wrote:
>
> Hi Bruno,
>
> On Sun, Mar 03, 2024 at 01:45:37PM +0100, Bruno Haible wrote:
> > Alejandro Colomar wrote:
> > > man2/clock_nanosleep.2 | 20 ++++++++++----------
> > > man2/nanosleep.2 | 12 ++++++------
> >
> > The change to nanosleep.2 seems mostly fine. Except that the
> > term "requested relative duration" (line 142) raises questions;
> > what about changing that to "requested duration"?
>
> Yeah, I had doubts about that one. Probably I should drop 'relative'.
>
> >
> > The change to clock_nanosleep.2 seems wrong. There are two cases
> > (quoting the old text):
> >
> > If flags is 0, then the value specified in request is interpreted
> > as an interval relative to the current value of the clock
> > specified by clockid.
> >
> > If flags is TIMER_ABSTIME, then request is interpreted as an
> > absolute time as measured by the clock, clockid. If request is
> > less than or equal to the current value of the clock, then
> > clock_nanosleep() returns immediately without suspending the calling
> > thread.
> >
> > In the first case, the argument is a duration. In the second case, the
> > argument is an absolute time point; it would be wrong and very confusing
> > to denote it as "duration".
>
> Hmm, thanks! I guess we'll have to keep 'request' in clock_nanosleep(3)
> unless someone comes up with a better name. Elliott, you may want to
> partially revert that change in bionic.
thanks! https://android-review.googlesource.com/c/platform/bionic/+/2987070
changes to
/**
* [clock_nanosleep(2)](http://man7.org/linux/man-pages/man2/clock_nanosleep.2.html)
* sleeps for the given time (or until the given time if the TIMER_ABSTIME flag
* is used), as measured by the given clock.
*
* Returns 0 on success, and returns -1 and returns an error number on failure.
* If the sleep was interrupted by a signal, the return value will be `EINTR`
* and `remainder` will be the amount of time remaining.
*/
int clock_nanosleep(clockid_t __clock, int __flags, const struct
timespec* _Nonnull __time, struct timespec* _Nullable __remainder);
> Have a lovely day!
> Alex
>
> --
> <https://www.alejandro-colomar.es/>
> Looking for a remote C programming job at the moment.
More information about the Libc-alpha
mailing list