[PATCH 1/8] malloc: Add specialized dynarray for C strings
Adhemerval Zanella
adhemerval.zanella@linaro.org
Tue Nov 21 16:32:00 GMT 2017
On 21/11/2017 12:19, Andreas Schwab wrote:
> On Nov 21 2017, Adhemerval Zanella <adhemerval.zanella@linaro.org> wrote:
>
>> // c == 's'
>> char c = char_array_pos (&str, 2);
>
> I'd call it char_array_at.
>
> Andreas.
>
Since char_array is based directly on dynarray the name is already implemented
by it. In fact we do have a char_array_at, but it returns a 'char *' to the
position.
More information about the Libc-alpha
mailing list