[PATCH] linux: spawni.c: simplify error reporting to parent

Rasmus Villemoes rv@rasmusvillemoes.dk
Fri Sep 23 19:09:00 GMT 2016


On Fri, Sep 23 2016, Florian Weimer <fw@deneb.enyo.de> wrote:

> * Rasmus Villemoes:
>
>> +      ec = args.err;
>> +      assert (ec >= 0);
>> +      if (ec != 0)
>> +	  __waitpid (new_pid, NULL, 0);
>
> One minor issue: Now that the variable name “ec” appears in an
> assertion, it is a good idea to rename it to “error_code_from_child“
> or something similar, so that the assertion message is more
> meaningful.

IMO, that's already addressed by the comments above the initialization
in the parent and exit path in the child. An assert message would have
to be overly verbose to make sense without the context of the code it
appears in. In any case, error_code_from_child is a bad name if we hit
the "ec = -new_pid" branch.

Rasmus



More information about the Libc-alpha mailing list