* Rasmus Villemoes: > + ec = args.err; > + assert (ec >= 0); > + if (ec != 0) > + __waitpid (new_pid, NULL, 0); One minor issue: Now that the variable name “ec” appears in an assertion, it is a good idea to rename it to “error_code_from_child“ or something similar, so that the assertion message is more meaningful.