[PATCH 1/2] Add framework for tunables

Siddhesh Poyarekar sid@reserved-bit.com
Tue Jan 12 02:18:00 GMT 2016


On Mon, Jan 11, 2016 at 07:02:46PM +0000, Joseph Myers wrote:
> On Mon, 11 Jan 2016, Siddhesh Poyarekar wrote:
> 
> > +# * False positive: tunable_register, compat_tunables_init_envvars,
> > +# tunables_init.  These functions are in the glibc internal namespace.
> >  @whitelist = qw(stdin stdout stderr re_syntax_options matherr matherrf
> > -		matherrl);
> > +		matherrl tunable_register compat_tunables_init_envvars tunables_init);
> 
> I don't understand this comment.  None of those names are in an internal 
> namespace.  All those functions should be renamed to start with __.

Oh, I meant that they're in the GLIBC_PRIVATE namespace.  In any case,
I'll remove these aliases and make libc_hidden_def instead to get
__GI___* for internal use.

Thanks,
Siddhesh



More information about the Libc-alpha mailing list