[PATCH 1/2] Add framework for tunables
Joseph Myers
joseph@codesourcery.com
Mon Jan 11 19:02:00 GMT 2016
On Mon, 11 Jan 2016, Siddhesh Poyarekar wrote:
> +# * False positive: tunable_register, compat_tunables_init_envvars,
> +# tunables_init. These functions are in the glibc internal namespace.
> @whitelist = qw(stdin stdout stderr re_syntax_options matherr matherrf
> - matherrl);
> + matherrl tunable_register compat_tunables_init_envvars tunables_init);
I don't understand this comment. None of those names are in an internal
namespace. All those functions should be renamed to start with __.
--
Joseph S. Myers
joseph@codesourcery.com
More information about the Libc-alpha
mailing list