[PATCH] remove nested functions from elf/dl-load.c

Konstantin Serebryany konstantin.s.serebryany@gmail.com
Wed Oct 8 22:50:00 GMT 2014


Please take another look.

2014-10-08  Kostya Serebryany  <konstantin.s.serebryany@gmail.com>

        * elf/dl-load.c
        (add_path): New function broken out of _dl_rtld_di_serinfo.
        (_dl_rtld_di_serinfo): Remove that nested function.  Update call sites.

On Wed, Oct 8, 2014 at 3:20 PM, Roland McGrath <roland@hack.frob.com> wrote:
>> +  struct add_path_state p = {counting, 0, si,
>> +    (char *) &si->dls_serpath[si->dls_cnt]};
>
> Indent the initializer properly.  It's easier to read if you use tagged
> member initializers too.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: unnest-dl-load-2.patch
Type: text/x-patch
Size: 4042 bytes
Desc: not available
URL: <http://sourceware.org/pipermail/libc-alpha/attachments/20141008/892cda6b/attachment.bin>


More information about the Libc-alpha mailing list