PowerPC LE configury
Bill Seurer
seurer@linux.vnet.ibm.com
Wed Nov 6 21:41:00 GMT 2013
Late follow-up to
https://sourceware.org/ml/libc-alpha/2013-08/msg00595.html from august.
Sorry if this breaks the original thread.
I have been looking at the idea for changing how the .abilist files are
found. To try it out I changed Makerules and some of the
configure-related files and I have it working in rough form. .abilist
files in a common directory with names modified to include an abi name
(like "ld.some_abi_name.abilist") are found first. If an .abilist file
is not found there the old names (sans .some_abi_name) and old search
method of using the sysdeps directories is used to find the file.
The question raised earlier in the thread and what I'd like to discuss
further is: what should the abi names look like? One proposal was
"This name may look similar to a GNU target triplet, but need not be
identical to one." (from
https://sourceware.org/ml/libc-alpha/2012-03/msg00589.html) These abi
names could be used for other purposes, too (as per that other thread).
Something to keep in mind is how to handle the search hierarchy (such as
it is) with the new naming scheme. I was using a powerpc64 system and
an x86_64 system for my testing and they used .abilist files out of
either sysdeps/unix/sysv/linux/<architecture> or sysdeps/generic but the
entire sysdeps tree (as architecture appropriate) is searched for the files.
--
-Bill Seurer
More information about the Libc-alpha
mailing list