Problem compiling gsl-1.1.1 under MinGW port of GCC 3.1

THEIS, Jochen, Group Risk
Tue Jun 11 14:49:00 GMT 2002


I just tried to compile the GSL version 1.1.1 with the MinGW port of GCC 3.1
(the MinGW release 20020516-1). I integrated the compiler in the Cygwin
environment (by setting the PATH variable appropriately) and ran
followed by
This worked fine with the cygwin port of GCC-2.95.3, but with the newer
compiler it gives the following error message:

prec.c:23:29: gsl/gsl_machine.h: No such file or directory
prec.c:24:31: gsl/gsl_precision.h: No such file or directory
prec.c:26: `_GSL_PREC_T_NUM' undeclared here (not in a function)
prec.c:26: confused by earlier errors, bailing out
make[2]: *** [prec.lo] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all-recursive-am] Error 2

when trying to compile "prec.c" in the "sys" directory. The files
"gsl/gsl_machine.h" and "gsl/gsl_precision.h" are present, and the error
also occurs when I run the compiler manually from the Windows shell. I have
also tried it on several different computers running different versions of
Windows (NT4, 2000 and ME), always with the same error message.

I do not know what to make of this error message; the compiler does not seem
to have a problem with include files in subdirectories of the include path
in other code that I compiled successfully with it. Can anyone help?

      Visit our Internet site at

This e-mail is intended only for the addressee named above.
As this e-mail may contain confidential or privileged information,
if you are not the named addressee, you are not authorised to
retain, read, copy or disseminate this message or any part of it.

More information about the Gsl-discuss mailing list