broken after libtoolswitch on

Brian Gough
Fri Feb 18 14:02:00 GMT 2000

The multilib example is interesting, and works for me. I tried to do
the same with the GSL, adding

bin_PROGRAMS = main dummy
main_SOURCES = version.c
main_LDADD = libgsl.a
dummy_SOURCES = version.c
dummy_LDADD = $(SUBLIBS)

with SUBLIBS = blas/libgslblas.a blas/libgslblasnative.a ... but I got
the same error,

make[2]: Entering directory `/home/bjg/gsl'
/bin/sh ./libtool --mode=link gcc  -g -O2  -o -rpath /usr/local/lib  version.lo blas/ blas/ block/ dht/ eigen/ err/ err/ fft/ histogram/ ieee-utils/ integration/ interpolation/ linalg/ matrix/ min/ monte/ multimin/ multiroots/ ode-initval/ poly/ randist/ rng/ roots/ siman/ specfunc/ statistics/ sum/ sys/ utils/ vector/ -lm 
libtool: link: error: cannot link shared libraries into libtool libraries
make[2]: *** [] Error 1

whenever I used pkglib_LTLIBRARIES for in the subdirectory's. It would only link if they were noinst_LTLIBRARIES.
Maybe I am doing something wrong.

More information about the Gsl-discuss mailing list