GDB 8.1 build error

Paul Koning paulkoning@comcast.net
Fri Apr 27 19:18:00 GMT 2018



> On Apr 27, 2018, at 3:01 PM, Simon Marchi <simon.marchi@polymtl.ca> wrote:
> 
> ...
> This seems to be a bogus error that was fixed in clang 3.9:
> 
> https://stackoverflow.com/questions/7411515/why-does-c-require-a-user-provided-default-constructor-to-default-construct-a?utm_medium=organic&utm_source=google_rich_qa&utm_campaign=google_rich_qa
> 
> You Apple LLVM 7.3.0 seems to map to upstream clang 3.8.0:
> 
> https://en.wikipedia.org/wiki/Xcode#Latest_versions
> 
> I indeed get the same error if I try building the file with clang 3.8 on Linux:
> 
> $ clang++-3.8 -x c++ -std=gnu++11 -g3 -O0 <snip> /home/emaisin/src/binutils-gdb/gdb/probe.c
> /home/emaisin/src/binutils-gdb/gdb/probe.c:63:28: error: default initialization of an object of
>      const type 'const any_static_probe_ops' without a user-provided default constructor
> const any_static_probe_ops any_static_probe_ops;
>                           ^
> 
> If compatibility with clang 3.8 is really important to you, we could always add an empty constructor to that class.  Otherwise, if it's easy for you to update your Xcode, I'd say try that first.

I foolishly assumed that the Apple updater would update Apple stuff.  And indeed it has given me bugfix updates to Xcode Command Line in the past.  But it doesn't do Xcode version updates.  

You're right, I'm way out of date, and that was unintentional.  I'm getting the latest now.  Will try with that and report.

	paul




More information about the Gdb mailing list