cat /proc/partitions shows only devices, not partitions

Hashim Aziz
Tue Mar 3 00:55:00 GMT 2020

Hey Corinna, thanks for your quick reply.

Regarding the elevated shell - I'm unsure of exactly how to run an elevated Cygwin shell?

I have attached the requested strace file.



From: Corinna Vinschen
Sent: Monday, March 02, 2020 4:56 PM
To: Hashim Aziz
Cc: cygwin
Subject: Re: cat /proc/partitions shows only devices, not partitions

On Mar  1 21:16, Hashim Aziz wrote:

> This was an issue that I had previously in September of last year and

> sent the issue to this mailing list ("win-mounts no longer displays

> anything when doing "cat /proc/partitions") but the issue stopped

> occurring before I could get around to diagnosing it. This issue has

> now re-occurred and this time it seems permanent. When I run:


> $ cat /proc/partitions

> major minor  #blocks  name   win-mounts


>     8     0         0 sda

>     8    16         0 sdb

>     8    32         0 sdc

>     8    48         0 sdd

>     8    64         0 sde

>     8    80         0 sdf


> ...I see nothing at all in the win-mounts column. This makes it

> impossible for me to see which Windows drive letter maps to which

> /dev/sdX entry. On closer inspection, this seems to be because I'm not

> actually seeing any partitions of my drives, even though there are

> many - for example, I see /dev/sda but no /dev/sda1 or /dev/sda2, and

> because it's the partitions that are mounted, it's this that seems to

> result in me seeing nothing in the win-mounts column. I'm running

> Cygwin on Windows 7 (yes I'm aware it's EOL).

Fortunately I just started Windows 7 for another thread here, so I

gave it a try myself:

  $ uname -a

  CYGWIN_NT-6.1 vmbert764 3.1.4(0.340/5/3) 2020-02-19 08:49 x86_64 Cygwin

  $ id -G | grep -Eq '\<544\>' && echo elevated || echo non-elevated


  $ cat /proc/partitions

  major minor  #blocks  name   win-mounts

      8     0  54525952 sda

      8     1    102400 sda1

      8     2  54420480 sda2   C:\


This appears to be a local phenomenon only, either some permission

problem, or some BLODA, a life virus scanner or something.

Two questions come to mind:

- Does it work in an elevated shell?

- If you run this under strace, does it show anything unusual?

  We could take a look if you call

    strace -o cat.trace cat /proc/partitions

  and send the cat.trace file here (assuming it still doesn't work).



Corinna Vinschen

Cygwin Maintainer

-------------- next part --------------
A non-text attachment was scrubbed...
Name: cat.trace
Type: application/octet-stream
Size: 42019 bytes
Desc: cat.trace
URL: <>
-------------- next part --------------

Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list