cat /proc/partitions shows only devices, not partitions

Corinna Vinschen corinna-cygwin@cygwin.com
Tue Mar 3 10:44:00 GMT 2020


On Mar  3 00:54, Hashim Aziz wrote:
> Hey Corinna, thanks for your quick reply.
> 
> Regarding the elevated shell - I'm unsure of exactly how to run an
> elevated Cygwin shell?

Right click on the Cygwin Terminal icon on the desktop, choose the
item "Run as administrator".

> I have attached the requested strace file.

Here's what I see for all partitions in the trace output:

  460   21259 [main] cat 553 format_proc_partitions: DeviceIoControl
  (Harddisk0\Partition0, IOCTL_DISK_GET_PARTITION_INFO{_EX}) Win32 error 5

Win32 error 5 is ERROR_ACCESS_DENIED.

So it appears that the OS access is denied for some reason.  I tried
again on Windows 7, this time with a non-admin account, just to be sure,
but I still can see the partition info.  Yesterday I tried with an admin
account, just not in an elevated shell, so this may have been an
important difference.  Apparently not so.

I have no idea why your system has different permissions, but at least
you should be able to see the info in an elevated shell.


Corinna

-- 
Corinna Vinschen
Cygwin Maintainer
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: not available
URL: <http://cygwin.com/pipermail/cygwin/attachments/20200303/b2b26fc4/attachment.sig>


More information about the Cygwin mailing list