configure with --enable-malloc-debugging fails to compile

Dave Korn
Thu Feb 14 09:41:00 GMT 2008

On 14 February 2008 05:36, Jim Kleckner wrote:

> Christopher Faylor wrote:
>> AFAIK, this option hasn't worked in quite some time, though, so I'd
>> be surprised to hear that it was this simple.
> Of course you are right :(
> There is a weird C++ constructor issue for mallinfo as Dave K pointed out.

  My patch does actually fix that: I was building the wrong sandbox when I
reported it before!

  I am currently running "make check".  When I have the results (and have then
run the tests on a clean repository, I've only got the "after" results so far)
and have done a bit of testing, I'll post it.

  Oh, hang on.  I'll have to go and double check.  I ran "cvs up" so it's
quite possible I've gotten the patch that removes the configure option.  Gah.
I'll have to do it all again tonight.

  At least part of the problem with the mallinfo stuff was that mallinfo has a
(k'n'r-style, no args) prototype at the top of that's just
outside #ifndef MALLOC_DEBUG when it should be inside so it doesn't get
__FILE__ and __LINE__ inserted into it.  That then makes it /look/ like a
files scope object being declared with a non-default c-tor, but it isn't.

Can't think of a witty .sigline today....

More information about the Cygwin-developers mailing list