Fix for ssh problems

Matt matt@use.net
Fri May 25 11:20:00 GMT 2001


On Fri, 11 May 2001, Christopher Faylor wrote:

> >As suggested before, I updated my gdb (to 20010428-1) and attempted to
> >attach to the ssh process. I got the same results as before: gdb misprints
> >the pid as a negative number, then uses 85% of the CPU. When I try to kill
> >gdb by closing the window, my machine becomes unresponsive (no capslock
> >or ctrl+alt+del reponse) for awhile, and
> >I've found it easier to reboot than wait for it to come back.
> >
> >Not sure what to do from here. Suggestions? Can someone else try attaching
> >to the process on win9x and seeing if gdb has the same result?
>
> Actually, I finally tried this and saw the hang.  I see the same hang with
> 1.1.8, too.  Isn't this the old "select doesn't detect EOF on a pipe" on
> Windows 95?

Sorry, replied to the previous message before seeing this one. Let me know
if there's any other debugging methods I can try to figure out the scp
problem.


--
http://www.clock.org/~matt



More information about the Cygwin-developers mailing list