Fix for ssh problems

Christopher Faylor
Fri May 11 16:26:00 GMT 2001

On Thu, May 10, 2001 at 11:24:27PM -0700, Matt wrote:
>On Fri, 4 May 2001, Christopher Faylor wrote:
>> Corinna reported a problem with sshd and debugged it enough that I
>> could (eventually) figure out what I think was happening.  I just
>> checked in a fix for the problem, I hope.
>> I don't know if this will fix Matt's ssh problems or not, but please
>> give the current CVS Cygwin a try.
>I just tried the 20010508 snapshot, which doesn't fix th problem on win9x.
>(The problem being that after scp'ing a file, an ssh process hangs
>As suggested before, I updated my gdb (to 20010428-1) and attempted to
>attach to the ssh process. I got the same results as before: gdb misprints
>the pid as a negative number, then uses 85% of the CPU. When I try to kill
>gdb by closing the window, my machine becomes unresponsive (no capslock
>or ctrl+alt+del reponse) for awhile, and
>I've found it easier to reboot than wait for it to come back.
>Not sure what to do from here. Suggestions? Can someone else try attaching
>to the process on win9x and seeing if gdb has the same result?

Actually, I finally tried this and saw the hang.  I see the same hang with
1.1.8, too.  Isn't this the old "select doesn't detect EOF on a pipe" on
Windows 95?


More information about the Cygwin-developers mailing list